Did we hear Mesh?

Just upload a Dutch Cow!

First of all.. Let's present our new logo designed by Netrex (sorry, dutch), the company behind the webserver and hosting of our domain. The previous one was 'designed' by me (Jabba), which was like... crap (my thought).

Second, we have some updates for the website coming along that includes a new chat system. This system connects a parcel/sim to the net, allowing people to chat in-world and on the web with each other. The first version of this ystem can already be used by going to the live chat system, go to our hangout in-world or go anywhere in-world through the viewer to Help->KirstensLive. Make sure you are registered to our forum to be able to login and use the chat.

With the new chat system (let's call it V2), I need volunteers to beta-test the system. If you are interested and want more details, contact me (Jabba Aabye) in-world.

Third. The new build, number 9. Builds for Windows and Linux are already online, Mac will follow soon. The main changes for this build are the bugs fixed in the cycle of S21(8) and, more important, the ability to upload mesh in the Agni (maingrid) sandboxes. And yes, view them too. It is merged with the latest updates from LL (version 2.8.2) with of course KL's own flavor of changes/fixes.

This summer has just begun, tho let me tell that most of the team is downsizing a little bit of work because of holidays/relaxing/lounging (Sorry for the southpart of the earth). Tho there are big changes coming from LL this summer that will make us do the necessary changes and keep you up to date.

Great love!

Jabba Aabye and the Team.

71 Comments

  1. Cincia Singh - July 23, 2011 at 23:29 Reply

    It's a great stable Windows build ... thank you all!

  1. Miguael Liamano - July 24, 2011 at 0:29 Reply

    I wish that the Disappearing UI bug will be squashed soon. I didn't had it before, and it's a real pita fest...

  1. Snodge - July 24, 2011 at 0:44 Reply

    Still getting lock ups when clicking anything in my inventory :( FPS is worse for me than build 8 too :( going back to build 8 now....only for the awesome fps tho, the inventory still sucks lol

    • Jabba Aabye - July 24, 2011 at 0:49 Reply

      More people have the problem you describe. I for one have no problems at all. It all runs really stable and smooth (FPS going above 75 in an agressive sim, GTX 285). Inventory even loads faster then normal.

      Maybe the amount of items in your inventory? And what settings/hardware do you have?

      • Arkem - July 24, 2011 at 7:30 Reply

        I have tried with two different profiles and the inventory lag is obviously related to the number of items, yes. The one under 10000 runs perfectly while the one over 30000 is unusable. But i can't drop 20000 items that easilly to become viewer2.8 compatible

      • Snodge - July 24, 2011 at 12:24 Reply

        i have had 37k inventory for the last year and the problem has only happened in build 8 and build 9 :( Im not deleteing all my creations and expensive stuff just because i have been on SL for years and have accumilated alot of things. thats kinda like saying you have been using SL too long, u must now suffer horrid horrid laggyness from now on! pfft

        • Snodge - July 24, 2011 at 12:39 Reply

          just instaled the newest LL v2 and the inventory is flawless. no freeze ups at all! and the FPS is awesome aswell. shame the UI is junk in LL v2

  1. belladonna - July 24, 2011 at 1:30 Reply

    I've been running this since yesterday nd my FPS is only about 18. This was the same issue I had when I went to build 8. Going back to 8RC3, that was the last stable and fast build for me, getting 40fps on that one. I can't live with 18 sorry!

  1. Niran - July 24, 2011 at 2:07 Reply

    aww , and i were totally worried that the Viewer is going to be inactive more and more ...phew *wipes off buckets of sweat from his head* , Build 9 is also running fine , fast n stable , Meshes work and upload work aswell excellent job!

  1. shirleymarquez - July 24, 2011 at 5:16 Reply

    There is indeed an inventory performance problem in build 9. One new thing in build 9 is that if you wear or attach something, the folder resorts with the worn item at the bottom of the list, so I suspect that part of the problem is that the viewer is triggering sort of the inventory windows too often. This is likely an upstream code change from LL.

  1. Stephanie - July 24, 2011 at 10:27 Reply

    i agree the framerate is quite low , but the viewer only uses 16% of the video card. I think it might have to do something with that. but then again i'm totaly not technical.

  1. Stephanie - July 24, 2011 at 10:32 Reply

    oops i just noticed the change when you have the viewer is on front instead of the background. in the background the fps is around 20 and in front it is between 60-90. So i geusse that is okay.

    • Cincia Singh - July 24, 2011 at 13:12 Reply

      Background yield time on the graphics/advanced/performance hardware tab determines how often the viewer updates SL when it's not the primary focus on your computer. This affects the fps.

  1. RL66 - July 24, 2011 at 23:13 Reply

    i guess something heavy have change since the "S21(8) without RC" even if the fps have risen to make SL usable, everything with S21(9) seem slower than other viewer... (yes, even firestorm) once switched back to S21(7) or S21(8)RC3 everything look like kirstens again... I hope it will be solved in S22 :) or S21(10).

    • Daria Shelman - July 25, 2011 at 0:20 Reply

      Kitty try reading what I wrote on "My story with S21 (8)" on the forums. I had the same problem but now V8 and V9 are as fast as RC3 for me. Well, roughly :)

  1. Lori - July 25, 2011 at 19:30 Reply

    Just out of curiosity, what's with the mac holdup?

  1. Bry Baxton - July 25, 2011 at 20:06 Reply

    any clue when the fix for the build tools will happen. I love this viewer but as a builder i need to know how many prims are in a linked item and with Kirstens the mesh info seems to push that off the screen. Thought it may be a issue coming from LL but none of the other viewers seem to have this.

  1. Cincia Singh - July 25, 2011 at 21:22 Reply

    I see a fix in the latest Snowstorm (development viewer) for both frame rate stutter on PCs and low FPS on Mac's.

  1. LOG123 - July 25, 2011 at 21:55 Reply

    Just a suggestion, Why not add in SSS (Subsurface Scattering) into the KV? I wonder how my av would look w/ that o.o

  1. Simon - July 26, 2011 at 3:26 Reply

    LOL, that's actually a good idea LOG123.

  1. unguent - July 27, 2011 at 4:11 Reply

    Yay! Kirstens is now officially the most stable TPV and most stable viewer overall - better than LL v2 - congrats and thanks for the hard work

  1. lulabyjj - July 27, 2011 at 4:27 Reply

    mac mac mac mac mac.......PLEASE!!

    • Jabba Aabye - July 27, 2011 at 9:47 Reply

      Mac has an unexpected delay because of an upgrade to Lion and breakage (for one) of python scripts (if I understood correct :P). There is being worked on..! :D

      • Daria Shelman - July 27, 2011 at 10:04 Reply

        I'm presently running S21 (8) on Lion and it looks like it's 2 times faster in any condition. Does it make sense? By the way, it appears totally compatible to me, but it's V8.

        • lulabyjj - August 02, 2011 at 7:27 Reply

          So sorry, I dont mean to be cruel. But should I even be expecting Mac version of (9) because it's been a while since he's released anything with an update on macs.

          • Billy - August 11, 2011 at 17:55 Reply

            When I turn on Lighting and Shadows, all objects with transparency disappear! Same thing with the Linden viewer (2.8 -- 2.7 works fine). I run SL on an ATI Radeon Mac.

  1. Gib - July 27, 2011 at 19:08 Reply

    Its great, but I dont think its more stable than Linden (unguent comment).
    For laggy place or place where there are a lot of people, Kirsten used to crash (for me at least) as Linden didnt.
    If I go a party I load Linden... :)
    Anyway, this version is great. Many many thx.

  1. Cincia Singh - July 28, 2011 at 14:07 Reply

    For me stability seems to depend on what activity I'm doing. For building and pure fps LL's development viewer is most stable and fastest. For photo work nothing can compare to KL's viewer. In busy clubs FS is most stable due to LAA, but it's definitely slower in fps than LL's dev viewer. Like mom taught me; use the right tool for each task.

  1. passing_party - July 30, 2011 at 6:52 Reply

    Rock stable on both the Phenom II x4 w/nVidia GTX 580 and the laptoppy i7 Core quad 2nd Gen. w/HD 3k Sandybridge + nVidia 555m. They BOTH crash on exit, so still no updates to last login screen on relog. Otherwise, frame rates are rock steady no matter the locale, activity with settings up around high quality. Ultra quality with shadows enabled makes the 555m sweat a little, but it's a mobile chipset with respectable 15 FPS. Desktop w/580 slashes through Ultra settings maxed out and shadows, occlusion, projectors and all reflections enabled @ about 60 FPS average.

    Thought I had a crash at login issue on the mobile, turns out that the Sandybridge unless I made an Optimus+nVidia control panel tweak would use embedded graphics. Making the 555m the default high performance device for use with Kirsten's resolved all issues, letting the driver make AA and AF decisions/overrides. Great stuff. :>

    Standard, LL Beta viewer runs like stink on either, even with shadows enabled. But w/out any DOF and other goodies that KV does, to be expected. It does not stress GPU hardware much at all.

  1. Altair - July 30, 2011 at 22:27 Reply

    for linux, the bug of tiled ground is fixed, S21(09b) on upload pending

  1. Imnotgoing Sideways - August 02, 2011 at 4:56 Reply

    I'm still seeing Nvidia OpenGL code4 and code8 crashes. I'm using the suggested 266.58 driver. LL clients still do it too. (._.)

    • Alysson Sophie - August 12, 2011 at 17:35 Reply

      Try Preferences>Graphics>Advanced>Perf-Hardware and uncheck "Enable OpenGL Vertex Buffer Objects", that did it for me, though you'll take a performance hit.

      It seems that the issue is due to changes in BOTH the recent LL code (it started on 2.8.x, some friends have reported it on V2 as well) and 266.58 or newer drivers... 270.xx and up seem to be pretty bad and 280.xx is pure garbage, crashing for me even unrelated games like left4dead and messing up Facebook images (won't display anymore) for a friend, in addition to causing Error 8 on SL for me and a friend.

  1. SLB - August 03, 2011 at 21:55 Reply

    Hi, I was thinking if there's a remote possibility to have the non web profiles back somehow since the viewer being mesh enabled and very good under many aspects, it's likely to be used on other grids too, where the profiles works the old way.
    I know maybe the old code has been stripped out or it's no use to make the profile system work in both ways maybe letting the user choose whether to use the web profiles or the standard ones, but it would be nice for grid portability to have both ways.

  1. Rc - August 06, 2011 at 23:43 Reply

    I never thought my pc could run Kirstens viewer. I gave it a try and was i amazed at how well it runs and the graphics are really nice. I am getting an average of 35fps and the sims load fast. This is what i use for hardware: CPU: AMD Athlon(tm) II X2 250 Processor (3013.74 MHz) Memory: 3071 MB OS Version: Microsoft Windows 7 32-bit Service Pack 1 (Build 7601) Graphics Card Vendor: NVIDIA Corporation Graphics Card: GeForce GT 220/PCI/SSE2/3DNOW! I also use it on a winXP computer and and it runs just as good. Try it out. Give it a spin. You may find awesome inside :-)

  1. Toppy - August 07, 2011 at 17:08 Reply

    I too am suffering the inventory lag (36K+ items), frame rates drop to 1.5fps when changing outfits .. but unlike the previous posters, I have tried both the latest LL Standard & Beta viewers and both display exactly the same inventory lag .. I can only assume that this is not a KV isssue but LL servers (yet again !) Keep up the great work guys ... KV is an awesome viewer !

  1. RL66 - August 08, 2011 at 21:32 Reply

    @all who suffer about inv lag: since few days this happen to all +15000 item avatar with any viewer based on 2... yes, it is (AGAIN lol) a LL issue. @RC kirstens is aimed as high end computer but it is faster on some low end (crap computer lol) too. despite i use it on Xeon in 8x4 , i have been pleased to have nice result on Celeron + 7600GS and on Atom + ION (yes even on a net computer :D ).

    • Alysson Sophie - August 12, 2011 at 17:42 Reply

      For those with inventory lag, try the instructions about setting up a persistent ramdisk cache on the page below (about half way down the page). This only works if you have more than 4GB of RAM (I suggest 6-8GB). After moving my KV and my Firestorm caches to the RAMDrive, I noticed little to no inventory lag (FS seems to have little to no inventory lag and KV's is much reduced) on my 24K inventory list.

      As a bonus side effect, rezzing on slow, laggy sims seems to be much improved as well. Since this will force you to clear your cache, when moving it to the RAMDisk, you will only see a noticeable difference on subsequent relogs, after your inventory has completely loaded and on repeat visits to a sim that you already have in your cache. The laggier rezzing is on that sim, the more improvement will be noticeable.

      • RL66 - August 13, 2011 at 15:47 Reply

        I totaly agree with that (i use it since a long time)... BUT (

  1. SLB - August 08, 2011 at 23:54 Reply

    Is it normal that the eyes don't render under water?

    • RL66 - August 13, 2011 at 15:40 Reply

      No :D it seem to be a bug

  1. Madrian - August 14, 2011 at 20:27 Reply

    this is becoming sort of ridiculous....where is the mac version of 9??

    • RL66 - August 14, 2011 at 23:01 Reply

      Better having a S21(8) that work than a S21(9) that is unstable. Anyway compiling on Mac when you don't have a nice one yourself is harder, i guess it is what make the mac release slower (i use hackintosh all work fine but when i compile all goes wrong).

  1. SLB - August 19, 2011 at 12:32 Reply

    Is it possible to remove the 64m limit on the viewer? Meshes are altready limited to 64m server side in SL grid so there would be no need imho to enforce it also on the viewer, furthermore, other grids don't have such limits and one might need/want to rely on the server size limits when applicable. I thought this was useful to say

    • Cincia Singh - August 22, 2011 at 14:14 Reply

      64m prims are only available in regions where Mesh has been enabled, not the whole grid. That means private estates that opted into the Mesh project, Magnum and Le Tigre sims, and Mesh sandboxes on the mainland. Other regions in SL allow only 10m prims at this time.

      • SLB - August 23, 2011 at 18:38 Reply

        I was talking about other grids where this limit doesn't exist, and by the way, mesh are being rolled out gridwise as I'm typing this.

  1. Simon - August 22, 2011 at 1:58 Reply

    Is there going to be a new update coming soon?

    • Nolo - August 23, 2011 at 15:40 Reply

      Kirsten isn't back from holiday so we only can wait and hope

  1. SLB - August 23, 2011 at 18:40 Reply

    Is there any chance to have the upload menu to show in non-build parcels? It's useful to upload from anywhere, then of course rez only where possible. I don't personally see any reason why an upload is constrained to be done only in build-enabled parcels.

  1. DomNagle - August 24, 2011 at 4:48 Reply

    i always wanted to ask this is kirsten stealing peoples passwords she admits to using google somethin for the passwords so it seems she is stealing peoples passwords is she ?

    • RL66 - August 27, 2011 at 12:47 Reply

      from my own knowing it is realy easy to do... BUT as it isn't allowed, you SHOULD'NT do it... KL is one of the most respectfull people in SL, i don't see any reason why he would do it. To be 99% sure to be safe use LL viewer (i know it is less fun :D ), to be 100% safe close your computer and cut your internet access point (lot less fun :( ).

    • RL66 - August 27, 2011 at 12:52 Reply

      About google it is usefull too to earn $ too and make a nice website but at low cost... everything that come from GoOgLe isn't necessary evil (despite it is the second big brother lol). Btw i am guilty too: i use gOoGlE too on my own stuff.

  1. Simondo Nebestanka - August 24, 2011 at 12:22 Reply

    @DomNagle Password theft must be the only possible explanation for using google somethin. I feel stupid for not realizing sooner.

  1. Adiicrowning - August 26, 2011 at 2:39 Reply

    BUUUUUMMMMMMMPPPPPPP......... :(
    i feel like KL left us in the dirt.

    • Cincia Singh - August 26, 2011 at 13:06 Reply

      KL has been on holiday. A well deserved holiday.

  1. Arriah - August 26, 2011 at 4:11 Reply

    I downloaded this, and when i log in i get this:
    www.flickr.com..
    I have a jagged line going through my screen, and my avatar wont load right. What should i do? I dont know if im allowed to ask here, but idk where else to ask D:

    • RL66 - August 27, 2011 at 13:01 Reply

      Nice boobs :) ... oups it isn't that we should look at =^.^= . try in debug setting to set renderlodvolume to a better value (i use 4 to 6 depend on the computer i am) it might help, else try play with shadow and light and tell us what is your configuration (computer type, OS, video card) to try to help you more...

      • Arriah - August 29, 2011 at 4:11 Reply

        My computer stats:

        CPU: Intel(R) Core(TM) i5 CPU 750 @ 2.67GHz (2664.79 MHz)
        Memory: 4088 MB
        OS Version: Microsoft Windows 7 64-bit Service Pack 1 (Build 7601)
        Graphics Card Vendor: ATI Technologies Inc.
        Graphics Card: AMD Radeon HD 6800 Series

  1. Sldappu - August 28, 2011 at 15:46 Reply

    Are the moving trees back yet? Its got to be my favourite feature. Makes the place look a bit less like legoland. Oh, and nice boobs Arriah :)

  1. Roger - August 30, 2011 at 19:59 Reply

    Do this release supports temporary textures? If yes how?

    • steelsnake - August 31, 2011 at 22:15 Reply

      Nope, does not support temp textures

  1. billy - August 31, 2011 at 16:46 Reply

    waits for mac.......

    • Simon - September 01, 2011 at 0:36 Reply

      @billy: i feel ur pain dude. Me too.....

    • prue - September 02, 2011 at 8:52 Reply

      Me too :( I'm now assuming we'll skip a build

      • Nolo - September 03, 2011 at 7:15 Reply

        Couldn't be there some how to that gives you some advance to build it your own?

      • billy - September 06, 2011 at 7:44 Reply

        sighs

  1. Cincia Singh - September 03, 2011 at 7:29 Reply

    It seems all the V2 TPVs are in a holding pattern ... waiting ... I assume Mesh upload issues are the reason, but I could be wrong.

  • Leave a comment - September 01, 2014 at 13:08